Dr. Martinus -Forum
Rund um Gott und die Welt
Bitte einloggen oder registrieren.
Heute ist der 23. November 2017, 08:32
Forum-Übersicht  Suche  Hilfe  Anmelden  Registrieren  Mitglieder

Neues Thema Antworten
Dr. Martinus -Forum :: Meine Software :: PBLang :: Attachments funktionieren leider nich!  ::
kai
Neuling
Bild

PBLang ist Super!
Nachrichten: 3
Attachments funktionieren leider nich! ( 9. Oktober 2004, 14:36) zitieren  
Hallo Allerseits,

erst einmal vielen Dank für die Super PBLang-Software. Ich bin recht begeistert, nur Attachments funktionieren bei mir leider nicht. Die Suche in diesem Forum hat auch nicht geholfen.

forum: www.toedter.com/forum
PBLang version: 4.60
Ordner attachments ist im mod 777
in settings.php steht $noatch="";

Wer weiss Rat?

Thanks

Kai


IP-Adresse gespeichert Status: ausgeloggt Profil ansehen 
Anordnung der Antworten: Erste Antwort zuletzt :: Erste Antwort zuerst
DrMartinus
Administrator
Bild
Bild
Hallo alle zusammen!
Nachrichten: 479
Antw.: Attachments funktionieren leider nich! ( 9. Oktober 2004, 16:52) zitieren  
Versuch's mal mit der php.ini (wenn Du dran kommst), oder frag Deinen host. Manchmal lassen die file uploads via PHP scripts nicht zu.


Dr. Martinus
www.drmartinus.de
IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
kai
Neuling
Bild

PBLang ist Super!
Nachrichten: 3
Antw.: Attachments funktionieren leider nich! ( 9. Oktober 2004, 18:48) zitieren  
Laut phpinfo():
file_uploads On

Ich bin kein Experte, interpretiere es aber so, dass uploads erlaubt von PHP aus erlaubt sein sollten.

Kai

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen 
DrMartinus
Administrator
Bild
Bild
Hallo alle zusammen!
Nachrichten: 479
Antw.: Attachments funktionieren leider nich! ( 9. Oktober 2004, 19:27) zitieren  
Stimmt. Da ist nur noch ein kleines Detail, das mir jetzt partout nicht einfallen will, irgend etwas anderes in der php.ini, das Du auch noch setzen müsstest... ich glaube, es hatte mit dem Safemode zu tun, bin aber nicht mehr so ganz sicher...
Ich werd mal sehn, ob ich das noch rauskriege.


Dr. Martinus
www.drmartinus.de
IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
kai
Neuling
Bild

PBLang ist Super!
Nachrichten: 3
Antw.: Attachments funktionieren leider nich! ( 9. Oktober 2004, 22:12) zitieren  
safemode ist leider "on", deswegen funktioniert file upload wohl nicht, habe ich auch mit einem simplen script testen können. Die php.ini kann ich leider auch nicht ändern (host ist Strato).

Gibt es in PBLang vielleicht einen Workaround für Strato? Bis auf den File-Upload funktioniert alles sehr gut.

Thanks

Kai

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen 
mattess
Neuling
Bild

PBLang ist Super!
Nachrichten: 1
Antw.: Attachments funktionieren leider nich! (12. Dezember 2004, 22:23) zitieren  
Hallo!

Auch von mir ein dickes Lob! PBLang ist wirklich ein gutes leicht zu bedienendes Forum. Allerdings habe auch ich das Problem, dass man nicht in die Foren uploaden kann. Der Ordner db\attachments fehlte bei mir. Habe ihn angelegt, Rechte vergeben, aber leider ohne Erfolg. Safemode (off).

Es kommt immer diese Meldung beim Versuch eine Datei in ein Forum upzuloaden.

"Es steht nicht genug Platz zur Verfügung, um diese Datei hochzuladen!"


Hat vielleicht mittlerweile jemand eine Lösung gefunden?

Gruß Matthias

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
DrMartinus
Administrator
Bild
Bild
Hallo alle zusammen!
Nachrichten: 479
Antw.: Attachments funktionieren leider nich! (17. Dezember 2004, 12:27) zitieren  
Kommt die Fehlermeldung von PBLang? Wenn ja, müsstest Du mal im admin-center schauen, ob dort eine Größenbeschränkung vorliegt, die greift. Es gibt zwei Einstellungen, einmal maximale Dateigröße und einmal verbleibender Speicherplatz. Beide müssten passend eingestellt sein.


Dr. Martinus
www.drmartinus.de
IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
mb1302
Neuling
Bild

PBLang ist Super!
Nachrichten: 4
Antw.: Attachments funktionieren leider nich! (10. Januar 2006, 02:03) zitieren  
Hallo,

bei mir kommt die Fehlermeldung von PBLang.
"Es steht nicht genug Platz zur Verfügung, um diese Datei hochzuladen!

Bitte kontaktieren Sie den Administrator unter xxx@dddd.xy
###################

Version ist die 4.65

../attachments erzeugt, hat 777 Rechte.

Einstellungen für Nachrichten:
Byte (0=unbegrenzt): 0
frei bleiben soll (in Bytes): 1000


Laut infophp.php sieht es so aus:
file_uploads On
safe_mode Off
upload_max_filesize 250M

sollte also passen.

Könnte das ein Problem sein?
upload_tmp_dir no value


lauft aktuell hier:
http://superbeetle.ktn-ev.de/forum/

Grüße
Manfred

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
mb1302
Neuling
Bild

PBLang ist Super!
Nachrichten: 4
Antw.: Attachments funktionieren leider nich! (10. Januar 2006, 02:04) zitieren  
Zitat:
Hallo,

bei mir kommt die Fehlermeldung von PBLang.
"Es steht nicht genug Platz zur Verfügung, um diese Datei hochzuladen!

Bitte kontaktieren Sie den Administrator unter xxx@dddd.xy
###################

Version ist die 4.65

../db/attachments erzeugt, hat 777 Rechte.

Einstellungen für Nachrichten:
Byte (0=unbegrenzt): 0
frei bleiben soll (in Bytes): 1000


Laut infophp.php sieht es so aus:
file_uploads On
safe_mode Off
upload_max_filesize 250M

sollte also passen.

Könnte das ein Problem sein?
upload_tmp_dir no value


lauft aktuell hier:
http://superbeetle.ktn-ev.de/forum/

Grüße
Manfred




so, ich habe jetzt das update auf 4.66z gefunden

ich kann damit kleine Anhänge (ca <10 kb) hochladen, mehr geht noch nicht ....

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
DrMartinus
Administrator
Bild
Bild
Hallo alle zusammen!
Nachrichten: 479
Antw.: Attachments funktionieren leider nich! (10. Januar 2006, 05:30) zitieren  
Es gibt dafür Einstellungen im admin-center, vielleicht haben die Einfluss darauf...


Dr. Martinus
www.drmartinus.de
IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
mb1302
Neuling
Bild

PBLang ist Super!
Nachrichten: 4
Antw.: Attachments funktionieren leider nicht! (10. Januar 2006, 11:21) zitieren  
Zitat:
Es gibt dafür Einstellungen im admin-center, vielleicht haben die Einfluss darauf...


Hallo,

vielen Dank für die schnelle Antwort,


Einstellungen müssten diese sein, habe da auch mit diversen Werten getestet.

Einstellungen für Nachrichten:
Byte (0=unbegrenzt): 0
frei bleiben soll (in Bytes): 1000


Wenn ich eine Nachricht "ändere", oder beim "antworten" funktioniert alles, ich kann Anlagen jeder Größe uploaden.

Nur beim Erstellen eines Eintrages funktioniet es sehr sehr selten, eher nie.

Die Filegröße hat keinen Einfluss.


Grüße
Manfred Braun

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
DrMartinus
Administrator
Bild
Bild
Hallo alle zusammen!
Nachrichten: 479
Antw.: Attachments funktionieren leider nich! (10. Januar 2006, 16:23) zitieren  
Das ist ein wichtiger Hinweis. Der hilft mir weiter:

finde eine Zeile in ntopic.php mit folgendem Inhalt:

if diskfreespace($mainpath.'/attachments')<$minspace){

und ändere die zu

if diskfreespace($mainpath.'/attachments')>$minspace){


Dr. Martinus
www.drmartinus.de
IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
mb1302
Neuling
Bild

PBLang ist Super!
Nachrichten: 4
Antw.: Attachments funktionieren leider nich! (10. Januar 2006, 17:29) zitieren  
Zitat:
und ändere die zu

if diskfreespace($mainpath.'/attachments')>$minspace){


DANKE! jetzt gehts!


Grüße
Manfred

IP-Adresse gespeichert Status: ausgeloggt Profil ansehen Webseite 
Neues Thema Antworten

Software PBLang 4.67.19.a © 2002-2006 by Martin Senftleben & the PBLang-Team
Die Verantwortung für die einzelnen Beiträge liegt voll und ganz bei den jeweiligen Autoren. Ich behalte mir das Recht vor, Mitteilungen zu löschen bzw. Mitglieder auszuschließen, falls diese gegen die Regeln der Menschlichkeit oder geltendes Recht verstoßen.
Bild